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1.

Introduction
This document explains the basic configuration of Brekeke PBX. For advanced configuration or
product architecture information, please refer to the Brekeke PBX Administrator’s Guide
(Advanced).

Brekeke PBX comes in two editions:


Brekeke PBX – IP-PBX software for single-tenant use (i.e., office PBX system)



Brekeke PBX MT Edition – IP-PBX for multi-tenant use (i.e., hosted PBX service)

2.

Installation

2.1.

Installation Options
Installer (exe format)

2.2.

OS

Windows OS

Install

New installation only

Instructions

Section 2.4 (Windows)

Memory

New installation
Update installation
Section 2.5 (Linux)
Section 2.6 (Update)



Microsoft Windows 2012 or later



Linux

2 GB minimum

Software Requirements
Java

Apache Tomcat

2.3.1.

Linux OS, Windows OS

System Requirements
OS

2.3.

pbx.war (zip format)

Java 7 or 8 (32-bit / 64-bit)
 Brekeke products are confirmed to run on Java provided by Oracle.

Version 7.x.x
 Tomcat installation is not required when Brekeke PBX is installed with the installer.

Installing Java SE

Instructions for installing Java can be found at our wiki:
http://www.brekeke.com/wiki/Installing-Java
7
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2.3.2.

Installing Apache Tomcat (required for Linux or manual install only)

Instructions for installing Java can be found at our wiki:
http://www.brekeke.com/wiki/Installation-of-Apache-Tomcat

2.4.

Installing on Windows OS with the Installer
1)

Download Brekeke PBX “Installer Executable (exe)” for Windows OS.

2)

Install the software following the installer’s instructions.

3)

Open http://localhost:18080/pbx/ (default) in a web browser.



If you select a customized port number during the installation, you need to set the port number in the
URL.

4)

Activate license following the instructions found in Section 3 of this document.

5)

At the login page, enter the user ID and password.



Default administrator login: user ID = “sa”, password = “sa”.

2.5.

Installing on Linux OS
1)

Download Brekeke PBX “Manual Install (zip)” for Linux OS.

2)

Copy the pbx.war file directly into the “webapps” directory, which is under the Tomcat
installation directory.

3)

Start Tomcat.



To confirm if Tomcat is running, open http://localhost:8080 in a web browser. (If you select a
customized port number during the installation, you need to set the port number in the URL.) When
you see the Apache Jakarta Project page, Tomcat has been started successfully.

4)

Open http://localhost:8080/pbx/ in a web browser.



If you select a customized port number during the installation, you need to set the port number in the
URL.

5)

Activate license following the instructions found in Section 3 of this document.

6)

At the login page, enter the administrator user ID and password.



Default administrator login: user ID = “sa”, password = “sa”.

2.6.

Minor version updates
1)

Download Brekeke PBX “Updates & Upgrades (zip).”

2)

Shut down Brekeke PBX from Brekeke PBX Admintool > [PBX] > [Start / Shutdown].

3)

Open [Maintenance] > [Update Software].

4)

Click [browse] to select the “pbx.war” file that you downloaded in Step 1.

5)

Click [upload] to upload the new file.
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6)

Restart your computer to complete updating Brekeke PBX.

3.

Activation

3.1.

Type of Activations

Brekeke offers two types of activation methods for our products: online and offline activation.

3.1.1.

Online activation



Requires the Brekeke software to be connected to the Internet at all times.



Allows unlimited instant license transfers.

3.1.2.

Offline activation



Able to activate the software without internet access.



Must contact Brekeke to transfer license. The maximum number of transfers per license is
three and is subject to our License Transfer Policy.
http://www.brekeke.com/purchasing/license-transfer-policy.php

3.2.

Initial Activation

Instructions for how to activate Brekeke software can be found at our wiki:
http://www.brekeke.com/wiki/Activating-from-Admintool-initial-installation

3.3.

Reactivating License

You will need to reactivate license when:


Adding users



Adding options



Adding codec license



Upgrading editions



Activation failure (i.e., lost online access)



Transfer license



Major version upgrade

Instructions for how to reactivate Brekeke software can be found at our wiki:
http://www.brekeke.com/wiki/update-license-change
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4.

System and User Management

4.1.

Administrators

There are three types of administrators for Brekeke PBX:


System Administrator – The top-level, fully authorized administrator.



Account Administrator – Administrator for single-tenant PBX. Privileges of the Account
Administrator are assigned by any administrator.



Tenant Administrator (available only for MT Edition) – Administrator for MT Edition. This
type of administrator has privileges only for the tenant they administer. Privileges are
assigned by any administrator.



For Brekeke PBX MT Edition, default system administrator “sa” is the only administrator for the whole
system. The “sa” administrator needs to create a tenant administrator whenever a tenant is created.

4.2.

Users

4.2.1.

Creating Users

1)

Log in as system administrator “sa”.
Go to [PBX] > [Extensions] > [Users] page.
For Brekeke PBX MT Edition, go to [PBX] > [Tenants]. Click [New Tenant] to create a new
tenant. When the tenant page opens, go to [Extensions] > [Users] page.



Super admin “sa” cannot be deleted.

2)

Click [Create a new user]. At the user [Account] page, set up the user account information.
Example:
[Extension] 300
[Login Password] your_password (password used to log in to Brekeke PBX Admintool).
[User Type] (select Admin or User)



There is no default user login password. If no login password is set at the time a user is created, that
user cannot log in to the account from Brekeke PBX Admintool.

4.2.2.

User Access Settings

The System Administrator (sa) can limit access to various Brekeke PBX menu settings in the
[PBX] > [Options] > [User Access Settings] section. This selection will be applied to all
administrators and users in the system. Note that the items in the [Admin Menu] sections are
only available to administrators.
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4.2.3.

Default Values of User Extensions

The following table outlines the default values included for Brekeke PBX user extensions. If you
change these settings, the functionality of the product may differ from the examples shown in
this manual.

To change user settings, click a user’s extension number from the [PBX] > [Extensions] >
[Users] list, or select a user from the [User] drop-down menu on the left-hand panel.
In Brekeke PBX MT Edition, go to [PBX] > [Tenants], click on the user’s tenant name and go to
the [Extensions] > [Users] page.

Page name

Settings

Setting item

Details of default values

Call pickup group

Same group as the administrator

Greeting message

Default system greeting

Email notification

off

Phone 1 > [Phone ID]
Phones

- Same as user extension
- <tenant>_<extension> (MT Edition)

Type

Type 1

Plan

Plan 1 (Active)
All phones are selected as
forwarding destinations. When an

Forward To >

[Phones]

incoming call to this user is received,
Brekeke PBX will forward the call to
all phones.

Inbound
Forward To >
Forward To >

[Ringer Time (sec)]
[Forwarding
destinations (Busy)]

90 seconds
Forwards to user’s voicemail

[Forwarding
Forward To >

destinations (No

Forwards to user’s voicemail

answer)]
Account
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who created this user

4.2.4.

Assigning Phones to User Extensions

Up to four different phone IDs can be assigned to each Brekeke PBX user extension. The
default phone ID is assigned in the [Phone 1] > [Phone ID] field and is the same as the Brekeke
PBX user extension from when this user was created. For Brekeke PBX MT Edition, it is in the
format of tenant name and user extension (as <tenant_name>_<extension>).

The phone ID field can be a SIP UA’s user ID, which is registered at the bundled SIP server of
Brekeke PBX, or a PSTN (analog or mobile) number that belongs to the user of this Brekeke
user extension. Any devices with a phone ID number assigned to the user extension can use
features of Brekeke PBX, such as call conference and call recording.

For Brekeke PBX MT Edition, we recommend using the format <tenant_name>_<extension> as
the SIP UA’s ID (phone number) used to register in the bundled SIP server of Brekeke PBX.
This will make phone ID management much simpler and will also help to avoid ID conflicts
among different tenants within the same system.

4.2.5.

Phone Type

System administrators can define customized phone types at [PBX] > [Options] > [Phone Type].

In v3.4.X or later, Brekeke PBX supports WebRTC. If WebRTC clients connect to Brekeke PBX,
system administrators need to make WebRTC available at “Phone Type.” You can set it as
follows:
1) Select phone type at [PBX] > [Options] > [Phone Type], then set WebRTC to “yes.”
2) Enable changed phone types as follows:
v3.3 or earlier -> Restart PBX
v3.4 or later -> Push “Apply” button on [Phone Type] page (no need to restart PBX).

You also need WebSocket handling available to use WebRTC connection.
[SIP SERVER] > [Configuration] > [SIP] > [WS (WebSocket)] > [WS-handling] on

4.3.

Tenants (MT Edition)

For Brekeke PBX MT Edition, the system administrator needs to create a tenant account for
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each tenant.

1)

From [PBX] > [Tenants], display all current tenants.

2)

In this example we will create a tenant named "test."
Click on [New Tenant] to input "test" as the tenant name.

3)

Once the tenant is created, go to the tenant setup menu by clicking on the tenant’s name.

4)

Click the [Options] menu under this tenant to set the tenant users and session limits from
the [Capacity] section, then enable the required features for this tenant from the [Features]
section.



Lower-case letters, digits, dots and underscores are valid characters for tenant names.

5.

PBX Features

5.1.

Call Forwarding

With Call Forwarding, you can forward your calls to another phone number, such as an operator
or your mobile phone. You can set up Call Forwarding to automatically forward all calls or just
certain ones depending on how they were missed (busy, after ringing, etc.).

These settings are configured at [User] > [Inbound] > [Call Forwarding].

5.1.1.

Forward Calls to Multiple Phones

Example:
In this example, calls to extension 301 will be also forwarded to extension 300:
1)

In user extension 301’s [Other Forwarding Destinations*] field, enter the user extension
number to which you want to forward the call. In this case, enter user extension “300.”

2)

Make a call to extension 301. Both phones assigned under user extension 300 and 301 will
ring.

5.1.2.

Setting Up No Answer Call Forwarding

You can set a number to forward calls that are missed after the Ringer Time period has been
reached. (“Ringer Time” is set under [Call Forwarding] > [Ringer Time (sec)].)
In this example, missed calls to extension 301 will be forwarded to extension 300.
Example:
1)

In extension 301’s [Forwarding destinations (No answer)] field, enter user extension “300.”

2)

Incoming calls will be forwarded to user extension 300 if extension 301 does not answer
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before ringer timeout.

5.1.3.

Setting Up Busy Call Forwarding

You can set a number to forward calls that are missed when the line is busy.
In this example, missed calls to extension 301 will be forwarded to extension 300.
1)

In user extension 301’s [Forwarding destinations (Busy)] field, enter user extension “300.”

2)

Calls will be forwarded to 300 if user 301’s phones return a 486 Busy response or another
error response.

5.1.4.

Scheduled Call Forwarding

This feature is useful for creating scheduled rules to forward calls, such as calls received
outside of business hours.

These settings are configured at [User] > [Inbound].

In this example, incoming calls during business hours to extension 5555 are directed to
extension 1002 (Auto Attendant). After business hours, callers are scheduled to forward to
extension 1003 and the caller will hear, “To speak with a live operator, please call during regular
business hours. Our regular business hours are Monday through Friday, 9 am to 6 pm.”

Example:
1)

Create an IVR extension 1003 (Type: Auto Attendant) and upload the customized
after-hour greeting from [Greeting messages].

2)

From [Extensions] > [Schedule], click [Create a new schedule].

3)

Enter below and save:
[Extension] 5555
[Default Forwarding Schedule] > [Call Forwarding] > [Destination] 1003

4)

Click [Add Forwarding Schedule] on the right side of the screen on the [Schedule] page.
Set [Forwarding Schedule 1] as:
[Forward To] > [Call Forwarding] > [Forwarding Destination] field to 1002.
Click [Conditions] tab and set the [Date/Time] section as:
[Term] set schedule starting and ending Date and Year.
st

th

[Days] Check 1 - 5 and Monday through Friday.
[Time] select and check 9:00 - 18:00.
Save
14
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5.2.

Ring Group

In this example, a Ring Group (3000) is created for all user extensions 301-305. When calls are
received at group extension 3000, all specified group extensions (301-305) will ring
simultaneously. If no one answers the call within the ringer time (90 seconds), the call is set to
be forwarded to user extension 300.
Example:
1)

From [PBX] > [Extensions] > [Groups], click [Create a new group].

2)

Set as follows:
[Extension] 3000
[Type] Simultaneous Ring
[Group Extensions*] 301,302,303,304,305
[Ringer time (sec)] 90
[Forwarding destination (No answer)] 300
[Tag] via 3000

3)

Save



From Brekeke PBX v3.4.x or later, the Tag feature is available. The value of the field is displayed
in the group extension's devices while ringing. If you use the Tag feature, you can set it from
[PBX] > [Option] > [Phone Type] > [Edit Phone Type] > [Tag in Display Name].

5.3.

Call Pickup Group

Call Pickup is a function that allows users to answer incoming calls from any extension by
dialing a preset number. When an extension rings, dial *<user extension> to answer the call. For
example, when user extension 300 rings, dialing *300 will enable you to answer the call from
any other extension within the system (or within the tenant for MT Edition).


If you are using a SIP phone that has a “Call Pickup” button, consult the manufacturer or your SIP
phone’s manual on how to use the Call Pickup feature.

Here are some other ways of using the Call Pickup feature:
Example:
Extension: 3000
Group Extensions*


301,302,303,304,305

Answer Calls That Are Directed to a Ring Group
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Calls received at a Ring Group extension can be answered from any extension by dialing
*<ring group extension>. In the above example, by dialing *3000, you can pick up a call
directed to Ring Group 3000.


Create a Call Pickup Group
By using the Ring Group setting, you can create a Call Pickup Group. In the above
example, dialing *3000 enables a user to pick up calls for the Ring Group, or any calls
directed to an extension in the Ring Group. In other words, by dialing *<ring group
extension>, you can pick up a call that came in for a single extension (e.g., 303) within the
Ring Group.

5.4.

Call Hunting

With Call Hunting, you can forward calls to multiple lines or phone numbers until it finds one that
answers.

These settings are configured at [PBX] > [Extensions] > [Groups].

Example:


Click [Create a new group].



Enter/Select the following values:
[Extension] 3001
[Type] Call Hunting
[Mode] Round-robin (or Top-down)
[Hunt group extensions*] 301,302,303,304,305
[Ringer time (sec)*] 5
[Waiting time in the queue (sec)] 120
[Max number of calls in the queue] 10
[Call interval (msec)] 3000
[Single attempt] no
[Forwarding destination (No Answer)] 300



Save

In this example, the call will ring the extensions in the [Hunt group extensions*] field one-by-one
with a five-second interval (Ringer time) between calling each user extension. If all of the
extensions (301-305) in the group are busy or do not answer, the call will be queued. If any
16
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member becomes available within 120 seconds (the interval set in [Waiting time in the queue
(sec)]), the call will be directed to the first available extension in the group. If the call is not
answered within the ringer time length set for the extension, the call will hold for the time set at
[Call interval (msec)](3000ms) before trying the next available extension in the group. If the
specified interval set at [Waiting time in the queue (sec)] is reached, the call will be forwarded to
the destination set in [Forwarding destination (No answer)]. In this example, the call will be
forwarded to user 300.



5.5.

The hold music can be customized in the [Sound files] > [Music on hold] field.

Auto Attendant

These settings are configured at [PBX] > [Extensions] > [IVR].

Example:
1)

Click [Create a new IVR].

2)

Enter/Select the following values:
[Extension] 3002
[Type] Auto Attendant
[Max input digits] 3
[Max retry count] 5
[Ring timeout (sec)] 10
[Default operator] 300
[DTMF timeout (sec)] 20
[Transfer to unregistered users] disable

3)

Save

In this example, the incoming call to Auto Attendant 3002 will hear the default greeting voice
prompt to input an extension.

If there is no entry made for 20 seconds ([DTMF timeout (sec)]), the caller will be reminded to
enter a selection. After five tries with no input ([Max retry count]), the call will be forwarded to the
destination set at the [Default operator] field.

If the caller enters an extension number, the call will be transferred to the extension that
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p-adm-b3.6.2_161115

Brekeke PBX Administrator’s Guide (Basic)

BREKEKE SOFTWARE, INC.

matches the first three digits ([Max input digits]) of the entry. If the extension does not answer
the call within ten seconds ([Ring timeout (sec)]), the caller will be asked to enter a different
extension number.

When [Transfer to unregistered users] is enabled, the caller can apply Brekeke PBX features
from Auto Attendant, such as accessing a voicemail box, call pickup and so on.

When

[Transfer to unregistered users] is enabled, a proper value must be set in the [IVR] > [Max input
digits] field in order to allow a caller’s input.



Optionally, a customized greeting for Auto Attendant can be uploaded from the [Sound files] section.



In Brekeke PBX v3.4.5.1 or later, two separate timeout values for [DTMF timeout (sec)] can be set for
“before initial entry” and for “before completion entries,” separated by commas as below:
[DTMF timeout (sec)] 20,30

5.6.

Switch Plan

Switch Plan or Timer can be used to change a user’s forwarding destination temporarily and
quickly by making a different forwarding schedule plan active.

In this example, incoming calls during business hours go directly to user 300’s assigned
phone(s). However, during user 300’s lunch break, you can send incoming calls directly to
voicemail. User 300 can enter DND (Do Not Disturb) mode by switching between pre-defined
inbound plans to route incoming calls to his/her voicemail temporarily during lunchtime.

The following samples show two different ways of implementation. More samples about
changing active plan with switch plan are available at Brekeke Wiki:
http://wiki.brekeke.com/wiki/Switch-plan-in-user-extension

5.6.1.

Sample with Switch Plan IVR Extension

Step 1: Setting Up a Switch Plan Extension
1)

From [Extensions] > [IVR], click the [Create a new IVR] button.

2)

Set as follows:
[Extension] 3004
[Type] Switch Plan
[Plan number] 2
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[on/off] yes
3)

Save the settings.

Step 2: Setting Up Plans in User Extension
1)

From the user extension 300 > [Inbound] page, click the [Add new plan] button.
“Plan 2” will show up in the plan dropdown list window.

2)

Uncheck all phones listed in Plan 2 and set [Other Forwarding Destinations*] as “vm300.”

3)

Save the settings.

Step 3: Enter “Do Not Disturb” Mode
1)

User 300 dials the Switch Plan extension 3004 from his/her phone to enter DND mode.
At user 300 > [Inbound] page, Plan 2 will be set as active.

2)

Any calls to user 300 at this time will be directed to user 300’s voicemail inbox.

Step 4: Remove “Do Not Disturb” Mode
1)

User 300 dials Switch Plan extension 3004 from his/her phone again to remove DND
mode.
At the user 300 > [Inbound] page, Plan 1 will be set as active again.

2)

5.6.2.

After exiting DND mode, any calls to user 300 will be directed to his/her assigned phone(s).

Sample with Timer

Step 1: Setting Up Plans in User Extensions
1)

At the user extension 300 > [Inbound] page, click the [Add new plan] button.
“Plan 2” will show up in the plan’s dropdown list window.

2)

Uncheck all phones listed in Plan 2 and set [Other Forwarding Destinations*] as “vm300.”

3)

Save the settings.

Step 2: Setting Up Timer
1)

At the user extension 300 > [Inbound] page, click [Timer 1].

2)

Set Timer 1 as below:
[Term] Set Schedule starting and ending Date and Year.
st

th

[Days] Check 1 - 5 and Monday through Friday.
[Time] Select and check:

3)

-

12:00 Plan 2

-

13:00 Plan 1

Save the settings.

Step 3: Enter “Do Not Disturb” Mode
Every workday at 12 pm, user 300 will enter DND mode.
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According to the user 300 > [Inbound] page, Plan 2 will automatically be set as active. Any
calls to user 300 between 12 pm and 1 pm will be directed to user 300’s voicemail inbox.
Step 4: Remove “Do Not Disturb” Mode
Every workday at 1 pm, Plan 1 on the user 300 > [Inbound] page will be set as active again.
After exiting DND mode, any calls to user 300 will be directed to his/her assigned phone(s).

5.7.

Conference Call

5.7.1.

Creating a Conference Room

The first step to using the Conference Call feature is to set up a Conference Room. In the
following example, extension 2000 is set up as the conference number:


If you are using a SIP phone that has a “Conference Call” button, please consult the manufacturer of
your SIP phone for information on how to set up the Conference Call feature.

1)

From [Extensions] > [Conference], click the [Create a new conference] button.

2)

Set as follows:
[Extension] 2000
Leave all other settings as default.

3)

Save the settings.

With the above settings, any user can enter the conference room by dialing 2000.

5.7.2.

Limiting Members Who Can Enter the Conference Room

You can limit the members who can join the conference by specifying individual members (for
example, “301, 102, 103”) at the [Applies to (Caller numbers)*] field. With this setting, only users
301, 102 and 103 will be allowed to join the conference. No other users can join this conference
room.

5.7.3.

Simultaneous Calls to All of the Conference Members

A conference member can convene all members of the conference room at once. For example,
set 301, 102 and 103 at [Forwarding destinations*]. By dialing 2000, all conference members
(301, 102 and 103) will be invited simultaneously.

5.7.4.

Starting a Conference Call (Alternate Methods)

The Brekeke PBX Users Guide describes additional methods for starting a conference call.
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5.8.

Callback

The Callback feature is a method of making low-cost international calls via a third country.
Brekeke PBX will ring a caller back when the caller dials the number of a Callback extension.

In the following example, extension 3000 is set up as a Callback extension:
1)

From [Extensions] > [Callback], click the [Create a new callback] button.

2)

Set as follows:
[Extension] 3000
[Ringer time (sec)] 90
[Forwarding destination (No answer)] 300
[Callback callee] 3002

3)

Save the settings.

When a caller dials a Callback extension, the caller will hear a ring tone. If the caller hangs up
before the ringer times out, Brekeke PBX will send an INVITE to the caller, who will then be
connected to the number set in the [Callback callee] field. In this example, the caller will be
connected to Auto Attendant 3002.

When a caller who dials a Callback extension does not hang up before ringer timeout, the call
will be directed to the destination set in the [Forwarding destination (No answer)] field.

5.9.

Confirm Call
1)

Go to [PBX] > [Voice Prompts] and upload an audio file named "confirmcall," which will
play a voice prompt to let the call recipient press a confirm key to establish the call.

2)

Go to [PBX] > [ARS] and create a new ARS Route to use Confirm Call, or to add the
Confirm Call setting to an existing ARS outbound route.

3)

At "Patterns – OUT" in the ARS Route, set the voice prompt name uploaded in step 1 to
[Confirm] field under [Deploy patterns]. You need to enclose the voice prompt name with
curly brackets "{" and "}". In this example, the [Confirm] field is set as {confirmcall}.

4)

Specify the confirm key in the [Key] field next to [Confirm] field. The default key is 5.

5)

Make outbound calls by applying the ARS route with confirm call setting. When the call
recipient answers the call, he/she will first hear the voice prompt "confirmcall." If the call
recipient presses the confirm key (5) from his/her phone keypad before the voice prompt
ends, the call will be established between the caller and callee. Otherwise, Brekeke PBX
will disconnect the call.
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If the [Confirm] field is set to {confirmcall}{name:&f1}, then the callee will hear the caller’s name (if
available) or the caller’s phone number played after the voice prompt. In this case, you need to set
[From] field in the Matching patterns, e.g., sip:(.*)@

5.10. Paging
The phones that support paging will answer incoming calls automatically without taking the
handset off-hook when these phones receive the paging information sent in the SIP header from
Brekeke PBX.

A list of SIP phones that work with the Brekeke PBX paging function, as well as its sample
configuration are available at the Brekeke Wiki:
http://wiki.brekeke.com/wiki/paging-function_phone-list

5.11. Busy Lamp Field (BLF)
When there is a call to a monitored phone, the corresponding key lamp on the monitoring phone
will flash and the call can be picked up from the monitoring phone.

A list of SIP phones that work with these functions, as well as their sample configurations, are
available at the Brekeke Wiki:
http://wiki.brekeke.com/wiki/BLF-SCA-and-Presence

5.12. Presence
Brekeke PBX can handle presence SUBSCRIBE requests from phones and return NOTIFY
responses about the status of the monitored phones, such as "available" or "on the phone."

A list of SIP phones that work with these functions, as well as their sample configurations, are
available at the Brekeke Wiki:
http://wiki.brekeke.com/wiki/BLF-SCA-and-Presence

5.13. Shared Call Appearance (SCA)
Users can monitor the external line status and select an available line to place an outbound call
or to answer incoming calls.

A list of SIP phones that work with these functions, as well as their sample configurations are
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available at the Brekeke Wiki:
http://wiki.brekeke.com/wiki/BLF-SCA-and-Presence

5.14. Video
Video can be enabled from several locations in Brekeke PBX: Options, ARS Settings and User
Settings. Video setting enabled in the phone type set under Users > [Phones] -> [Phone Type]
has the highest priority. When the default setting is defined in [Phone Type] > [Video] field, the
video setting under [ARS] route will be applied if the call can apply any route. When video
setting in both User [Phone Type] and ARS route is set to the default, the [Video] setting at
[Options] will be applied to the call.

The following steps show how to enable video for the phone assigned to a Brekeke PBX user
extension.

1)

From [Options] > [Phone Type] page, create a new phone type

2)

At new phone type setting page, set [Video] field as on and set proper audio codecs in
[Codec Priority] field.

3)

Save the new phone type and restart Brekeke PBX from admintool.

4)

From a PBX user extension > [Phones] page, select the phone type created above at the
[Type] field under the phone which supports video for the call. And save the changes.

5)

The call between PBX users with video phone type or from/to external user through ARS
route with [Video] field set as "on" will have video feature.

5.15. Voicemail
5.15.1. Voicemail Settings
After creating user extensions, you can set up voicemail for each extension. If a call is missed
(eitther did not answer or busy) after the specified length of time at [Ringer Time] under the
Inbound setting, the call will be forwarded to voicemail by default. There is no default voicemail
access PIN set at the time a user is created, so set the user’s voicemail box PIN from the [User]
> [Settings] page.

By using preset prefixes, users can manage their voice messages using a dial keypad. The “vm”
prefix is specified under the “mediaserver_prefix” route at the ARS settings.


To go straight to voicemail, dial 07*<user extension>.
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To check voice messages from your phone (the phone assigned Phone ID), dial “8” to
reach your voicemail inbox.



To check your voice messages from another extension in the system, dial 08*<your user
extension>.

5.15.2. Voicemail Notification by Email
Step 1: Setting Up an Email Sender
Brekeke PBX supports mail servers that provide “POP before SMTP” authentication, “SMTP”
authentication or Encrypted Connection (SSL).
To set up an Email Sender:
1)

Enter your mail server information and email user account information at [PBX] > [Options]
> [Settings] > [Email settings].

2)

Set [Encrypted connection (SSL)] on or off, depending on your mail server type.

3)

Restart Brekeke PBX from Admintool to apply your changes.

Step 2: Setting Up an Email Recipient
1)

Navigate to the [Voicemail settings] section on a user’s [Settings] page.

2)

Set [Email address*] to the recipient’s email address(es).

3)

Set [Email notification] to “on.”

4)

Set [Attach WAV file to Email] to “on” or “off,” depending on whether you want to attach
voice messages to email.

5.15.3. Message Waiting Indicator (MWI)
If your SIP UA supports MWI with a “SUBSCRIBE” message, it will be activated by default. If
there is a special button on your SIP UA to retrieve messages, assign a number (default is “8”)
to retrieve voicemail messages. Some types of SIP UAs can automatically call the SIP URI that
is specified in the Brekeke PBX NOTIFY packet (for MWI) to retrieve the message without
assigning the number manually.

For those SIP UAs that do not send “SUBSCRIBE” messages for MWI, you can create a new
phone type and set the [MWI (NOTIFY without SUBSCRIBE)] field as “on” and select this phone
type from the PBX user extension [Phones] page where these SIP UAs are assigned. Then
Brekeke PBX will send a voicemail notification even if there is no “SUBSCRIBE” message for
the MWI sent from these SIP UAs.
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5.16. SRTP
From Brekeke PBX v3.2.x or later, Brekeke PBX supports SRTP.

SRTP can be enabled from several locations in Brekeke PBX: Options, ARS Settings and User
Settings. SRTP setting enabled in the phone type set under Users > [Phones] -> [Phone Type]
has the highest priority. When the default setting is defined in [Phone Type] > [SRTP] field, the
SRTP setting under [ARS] route will be applied if the call can apply any route. When SRTP
setting in both User [Phone Type] and ARS route is set to the default, the [SRTP] setting at
[Options] will be applied to the call.

5.17. ARS
In Brekeke PBX v3.0.x, by clicking a route name on the [ARS] > [Running Status] page, the
details of an active ARS route can be displayed. Also, from the [ARS] > [Settings] page,
administrators can perform numerous actions on an ARS route, such as copy, delete and edit.

From Brekeke PBX v3.1.x, by clicking [View] in the ARS route list’s [Status (Reg/Route)] column,
the details of an active ARS route can be displayed. An ARS rule can also be edited by clicking
the ARS route name. If the ARS rule is a template with the [Template] field checked, you can
click [Edit Template] on the [Variable Setting] page to change the template setup and the
variables’ setups for each route under the template.

In Brekeke PBX MT Edition, the tenant name needs to be set for any ARS rule that will be used
exclusively by a specific tenant. The tenant name is set in the ARS rule > [General] > [Tenant]
field.

By assigning a tenant name in ARS rules for inbound calls, Brekeke PBX MT Edition will
associate inbound calls with this tenant and will route inbound calls to the proper tenant
extensions.

By assigning a tenant name in the ARS rules for outbound calls, Brekeke PBX MT Edition will
look for the ARS route for this tenant, determine who the caller is and then route the call to the
destination set for this tenant. If no tenant name is assigned in the ARS outbound route, the
route will apply to calls from any tenant.
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5.17.1. Route Settings / Route Template


General
Use the [General] section to enable or disable either an ARS template or any of the
settings required by Brekeke PBX features, such as [Tenant] in MT Edition if you want to
restrict route usage to a certain tenant, the [LineKey] and [Resource] fields for Shared Call
Appearance, the [Group] field for ARS group, the [External] field for call logs database and
for billing and so on.



Registration
Register your VoIP gateway port SIP number at Brekeke PBX bundled SIP Server.
Brekeke PBX will accept calls from this gateway even if the gateway is not registered at
Brekeke PBX bundled SIP Server.

If a provider needs authentication information from a caller who makes outbound calls from
UAs to an ITSP, Brekeke PBX will send the username and password that are set in this
section to the provider in an IP address or in the domain set in the [Proxy Address] field.


Patterns
Define Patterns IN and OUT to receive and send calls from/to SIP devices and services.



Priority
It is useful to set priorities when there are multiple options for making calls, such as when
you have multiple PSTN gateways for outbound calls or when you subscribe to multiple
VoIP service providers. A lower number holds the higher priority.



Max Sessions
Set the [Max Sessions] field to define the maximum number of sessions that can be
handled by each pattern, such as when there is a limited number of Gateway channels or
subscribed lines for your SIP services. Setting this field to “-1” specifies an unlimited
number of sessions.

For ARS routes in the same group, there is only one session counter. The session counter
for the group will increase by one when there is a call through any ARS route in this group,
regardless of what is specified in Pattern IN or OUT. If this session counter is equal to any
pattern [Max Sessions] value that is set in the same group’s ARS routes, the next matched
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session cannot apply to this pattern (IN or OUT) or to any ARS routes when all of the
patterns’ [Max Sessions] for the ARS routes in the same group are set to the same value.

5.17.2. Global Route Variables (Brekeke PBX v3.1.x or later)
Global variables can be accessed from any ARS route. The update of a global variable will
affect the ARS routes in which the related variable name is set.

From [Field Settings], administrators can set a global variable’s field type, name and description,
and can also choose whether or not a global variable will be displayed on the ARS top page.

5.17.3. Variable Setting

Brekeke PBX v3.1.x or later
From the ARS template’s [Variable Setting] page, administrators can create routes that use the
same ARS patterns template and can also set the values of the variables to be used by each
route.


Common Settings
Common variables can be accessed from any route created under the same ARS template.
Updating a common variable will affect the ARS routes under the current ARS template.
From [Field Settings], administrators can set a common variable’s Field Type, Field Name,
Input Rule and Descriptions, and can also choose whether a common variable will be
displayed on the [Variable Settings] page.
Configuring [Field Settings] on [Common Settings] is the same as on [Route Local Settings].
For more configuration details, please refer to “Route Local Settings” in the next section..



Route Local Settings
Create new routes and assign values to the route’s local variables defined in the ARS
template for each route, and also deploy multiple routes based on the same ARS template.
From the [Field Settings] page, administrators can change the route’s local
variables’settings and also write JavaScript code to control the variable values set in each
route.
Sample script:
if( v1 == 3333 )
v5= "192.168.200.20";

27
p-adm-b3.6.2_161115

Brekeke PBX Administrator’s Guide (Basic)

BREKEKE SOFTWARE, INC.

else
v5= "192.168.200.30";

Set the above script in the [Route Local Settings] > [Field Settings] -> [Script] field. If a
route has variable v1 with value 3333, this route variable v5 will be set as “192.168.200.20”
automatically. The route variable v5 will be set as “192.168.200.30” when variable v1 is set
to any value other than 3333.
The table below shows an example of other items on the [Field settings] page.
If you choose “Select” as the Field Type, you should set an input rule in “Input Rule.”

Field

Variable

Field Name

Initial

Type

Input Rule

Value

Text

v1

Call Number

Select

v2

ITSP Type

003

[0-9]

*1

ITSP A:001;ITSP B:002;ITSP C:003;

*2

*1. When “Text” is selected as the Field Type, an Input Rule is not necessary. However, if
you set an input rule using a regular expression, Brekeke PBX will check variables
according to the rule on the [Variable Settings] page.
*2. When “Select” is selected as the Field Type, an Input Rule is needed. In the example,
according to the input rule, “ITSP A,” ”ITSP B” and “ITSP C” are displayed as options for
the select box on the [Variable Settings] page. “ITSP C” is displayed as the initial value of
the select box.

Brekeke PBX v3.0.x
The variables defined in an ARS route can be edited from the [Edit Variables] page at the
upper-right of the ARS route template.

Variables

Default value

v1

User ID/Number

v2

Password

v3 - v9

Customizable fields

5.17.4. ARS Default Plug-ins
Brekeke PBX offers the default plug-ins that use Notes. The default plug-ins are contains,
lookup, and matches.
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By using these plug-ins, you can search for a caller's number in a telephone directory (making
notes under [Options] > [Notes] to save data list) and handle the call as your need, such as,
decline the call, change the caller ID, or redirect the call.

For the details about the Brekeke PBX default plug-ins and how to configure ARS route to use
the plug-ins, please refer to “Developer's Guide: ARS plug-in”.
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5.18.

PSTN Access Using a VoIP Gateway

Using a SIP-compliant VoIP Gateway, Brekeke PBX users can receive calls from a Public
Switched Telephone Network (PSTN) and make calls to PSTN lines.

5.18.1. VoIP Gateway Setup
Set the following at your VoIP Gateway:
SIP proxy address

IP address of Brekeke PBX

Dialing number sent to Brekeke PBX

PSTN line number

5.18.2. ARS Route Setup
Set up “Patterns – IN” and “Patterns – OUT” in the default Gateway ARS Route to receive and
make calls from/to the Gateway.


Default ARS rule “gw1” is the setup template for one-stage dialing.



Default ARS rule “gw2” is the setup template for two-stage dialing.

Use the following settings to register the gateway at the Brekeke PBX bundled SIP server. Many
PSTN Gateways have a short interval between sessions, during which time the line is
unavailable. You can modify the [Session interval (ms)] field setting to reflect this delay as
needed.


In Brekeke PBX v3.1.x, check the [Template] field to enable the [Variable Setting] page.

[Registration]
Register URI

sip:&v1@127.0.0.1

Register expire (sec)

3600

Proxy address

127.0.0.1

Register update period (%)

90

User

Password

5.18.3. Receiving PSTN Calls
Create Gateway ARS Route “Patterns – IN” to receive calls from a gateway.
[Patterns – IN]
Matching patterns

Deploy patterns

From
To
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5.18.4. Calling PSTN Numbers
One-Stage Dialing
If your VoIP Gateway supports One Stage Dialing, a Brekeke PBX user can make a PSTN direct
call by setting an ARS Route as follows:

[Patterns – OUT]
Matching patterns

Deploy patterns

From
To

sip:([0-9]{7,25})@

sip:$1@gw_IPaddress

In this example, Regular Expressions were used to define the Matching and Deploy patterns. A
Brekeke PBX user who dials a number that has between 7 and 25 digits will be considered as a
PSTN call. Brekeke PBX will apply the above ARS Route and the call will be sent to the
gateway.

If you use multiple VoIP Gateways for outbound calls, you can define more detailed dialing
patterns in [Matching patterns] > [To], as well as change the [Priority] field as necessary to
define the usage order of Gateways. Please note that lower numbers hold the higher priority.
You can use the [Max Sessions] field to define the total number of sessions handled by each
pattern.

Two-Stage Dialing
If your VoIP Gateway supports Two Stage Dialing, have the gateway’s PSTN port register with
Brekeke PBX bundled SIP server. Let’s suppose the gateway’s PSTN port has the SIP user
name 111. To call a PSTN number, dial the gateway’s registered PSTN port number (in this
example, it’s number 111) and then dial the destination PSTN number. Alternatively, you can
configure the DTMF setting at the ARS Route OUT pattern so that the dialed numbers will be
sent to the gateway as DTMF tones.
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The OUT pattern to send a destination number by DTMF in Two-Stage Dialing is as shown
below:
Patterns – OUT
Matching patterns

Deploy patterns

From
sip:111(.+)@

To



From
To

sip:111@gw_IPaddress

DTMF

$1

If a delay is needed before sending a DTMF call, set the [DTMF] field as {file_name}$1. Default files
are {120ms}, {240ms}, {500ms}, {1sec} and {2sec}. Customized files can be uploaded from [PBX] >
[Voice prompts] and set [Language]: Common.

5.18.5. Assign Values to Variables
Click the [Variables] link at the upper-right corner of the ARS Route template page. At the
[Variable Setting] page, select [New Route] and assign values to the variables defined in the
above Patterns – IN and Patterns – OUT.
Route Name

Gateway1 (Brekeke PBX v3.1.x or later)

Tenant

A tenant name (MT Edition)

v1

PSTN line number set in section “VoIP Gateway Setup”

v3

Specify a Brekeke PBX extension number, such as 300.

5.19.

Connecting with Internet Telephony Service Providers (ITSPs)

5.19.1. Account Information for Third-Party SIP Server

Acquiring the information shown below is necessary to connect with a third-party SIP server.
Phone number

6504106636

SIP server IP address

sample_proxy.com

User ID

6504106636

Password

6636



Depending on the provider, there may be restrictions for connecting to services, such as available
information or equipment used to connect. Please contact your VoIP service provider for more
details.



Please note that we do not guarantee connection with third-party products.
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5.19.2. Setting ARS for ITSP using multiple accounts


In Brekeke PBX v3.1.x, check the [Template] field to enable the [Variables] setting page.

[Registration]
Field name
Register
URI
Proxy
address
User

Sample settings

Explanation

sip:&v1@sample_proxy.com

Enter SIP URI.
Can be omitted when Proxy address is

sample_proxy.com

field.
&v1

Set value at [Variables Settings] page.
Set value at [Variables Settings] page.

Password
(Brekeke

the same as the one in the [Register URI]

&v2

This field will be displayed in text format
after saving.

PBX v3.0.x)

[Patterns – IN]
In the Patterns – IN example below, Brekeke PBX user extension 300 (“&v3” value, set at the
[Edit Variables] page) is set to ring when a call comes through a third-party SIP server. Leaving
the “From” field blank carries over the Caller ID information.

To


Matching patterns

Deploy patterns

sip:&v1@

&v3

Check [Apply to Request URI instead of To] when To header sent from ITSP is different from To
defined in the ARS Route Patterns – IN.

[Patterns – OUT]
Patterns – OUT defines patterns for converting the SIP URI to match your VoIP provider’s
header format requirements. In the example below, dialed numbers with 7 to 25 digits will be
directed through the VoIP service provider. To ensure that the recipient’s caller ID display will
function, the “From header” will change according to the rules of the provider. Set [Priority] and
[Max Sessions] as you need.
Matching patterns

“&v1” <sip:&v1@sample_proxy.com>

From
sip:([0-9]{7,25})@

To


Deploy patterns

sip:$1@sample_proxy.com

Some VoIP service providers restrict the connection when the FROM or TO header information is
different from their own header format.
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[Variables ]
Click the [Variables] link at the upper-right corner of the ARS Route template page. On the
[Variable Setting] page, select [New Route] and assign values to variables defined in the above
Patterns – IN and Patterns – OUT.
Route Name

Route 6504106636 (Brekeke PBX v3.1.x or later)

Tenant

A tenant name (MT Edition)

Password / v2

6636

v1

6504106636

v3

Specify a Brekeke PBX extension number, such as 300.



For Brekeke PBX v3.0.x, set related variables from the [Edit Variables] page.

5.20. ARS Outbound Route Failover
Utilizing the Automatic Route Selection (ARS) outbound route failover feature allows users to
create redundant telecommunications systems. If an outbound route is not available or usable,
Brekeke PBX will direct the session to an alternative route.

5.20.1. Usage Examples


Brekeke PBX provides automatic failover to an alternative ITSP service in the event of a
failure at your specified ITSP service.



Brekeke PBX provides automatic failover to an analog telephone session via PSTN
Gateway in the event of a failure at your specified ITSP service.



Creating redundant analog telephone connections with multiple PSTN Gateways.

5.20.2. Settings Examples
The ITSP line is set for regular outbound sessions. When the ITSP line fails, the outbound
sessions will be routed through the PSTN Gateway.

In the following example, two ARS routes are created: “ITSP_A” and “MyGateway.” The route
with the highest priority, “ITSP_A,” will be used for outbound calls with a dialing numbers that
have 7 to 25 digits. If there is no response within four seconds (Response timeout: 4000 ms) for
INVITE messages or a “500-599” response is received, Brekeke PBX will continue searching for
the next route that matches the outbound session request. In this case, the next-highest
prioritized route, “MyGateway,” will be chosen as the alternative route for the session. Since the
recovery time is set to one hour (3600000 ms) in “ITSP_A,” the matching sessions will be routed
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p-adm-b3.6.2_161115

Brekeke PBX Administrator’s Guide (Basic)

BREKEKE SOFTWARE, INC.

through route “MyGateway” for one hour after the failover. If “ITSP_A” is running again within an
hour, the sessions will once again be routed through the highest priority route, “ITSP_A.”

Route name: ITSP_A
Patterns – OUT
OUT – 1
Priority
Max
sessions

Matching patterns

Deploy patterns

1

From

From

“xxx”<sip:xxx@itsp.com>

4

To

To

sip:$1@itsp.com

sip:([0-9]{7,25})@

Parameters
Next route on
failure
Response
timeout (ms)
Recovery
time (ms)



Yes

Disable on
registration failure

Yes

4000

Error codes

500-599

3600000

Disable on failure

This route

[Response Timeout (ms)] should be adjusted according to your environment. PSTN
Gateways and SIP servers located in the local network may not require this long of a
Response Timeout interval. For a route that requires an Internet connection or if some
other kind of delay is expected, the Response Timeout intervals should be set to a longer
time.



[Disable on registration failure] is set to “yes” in Route “ITSP_A.” When registration is not
working property at the “ITSP-A” route, it will be disabled and the “MyGateway” route will
be used instead.



[Disable on failure] is set as “This route,” which will disable the whole route. If there are
other IN/OUT patterns defined in this route, they will be unusable when failover happens. If
[Disable on failure] is set as “This pattern,” it will only disable the current pattern, so other
patterns in this route will still be usable.
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Route name: MyGateway
Patterns – OUT
OUT – 1
Priority
Max
sessions

Matching patterns

Deploy patterns

100

From

From

4

To

sip:([0-9]{7,25})@

To

sip:$1@GW_IPaddress

5.21. ARS Route with Resource Setting (Brekeke PBX v3.1.x or later)
When multiple ARS routes for Shared Call Appearance (SCA) are set with the same name in the
[Resource] field, Brekeke PBX SCA users will have more ARS route choices for making
outbound calls than by using the ARS settings without this [Resource] setup.

Set up the ARS template and Brekeke PBX users as described below and assign phones with
the Shared Call Appearance feature enabled to users.

Route Template:
[General]
Route name

outbound

Template

checked

Line key

checked

Resource

&v9

[Patterns – OUT]
OUT – 1
Priority
Max
sessions

Matching patterns

Deploy patterns

&v1

From

From

&v2

To

sip:([0-9]{7,25})@

To

sip:$1@&v3

Variable Setting:
Route Name

v1

v2

v3

v9

1

90

1

192.168.200.10

gw

2

90

-1

192.168.200.20

itsp

3

100

1

192.168.200.30

gw
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Brekeke PBX SCA Users
User: 300
[Settings] -> [Resource map]
line/1=gw/1
line/2=gw/2

User: 301
[Settings] -> [Resource map]
line/1=gw/1
line/2=itsp/1

When user 300 makes an outbound call from a phone with shared line 1, the call will apply route
“outbound*1” with resource set as “gw” and the call will be sent to the destination IP
192.168.200.10.

While user 300 is talking, if user 301 also makes an outbound call from shared line 1, the call will
apply route “outbound*3” with resource also set as “gw” and will be sent to the destination IP
192.168.200.30.

Because route “outbound*1” with resource “gw” has the [Max Sessions] variable v2 set to 1 and
one session from user 300 is using this route, Brekeke PBX looks for the next available route
with resource “gw” for the user 301 outbound call, which is route “outbound*3.”
If user 301 makes an outbound call from shared line 2, the call will apply route “outbound*2” with
resource “itsp” and will be sent to IP 192.168.200.20.

5.22. ARS Route with Group Setting
Set up the ARS template and Brekeke PBX users as described below and then assign phones
with the Shared Call Appearance feature enabled.

Route Template:
[General]
Route name

outbound

Template

checked
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Group

&v8

Line key

checked

Resource

&v9

[Patterns – OUT]
OUT – 1
Priority
Max
sessions

Matching patterns

Deploy patterns

&v1

From

From

&v2

To

sip:([0-9]{7,25})@

To

sip:$1@&v3

Variable Setting:
Route Name

v1

v2

v3

v8

v9

1

90

1

192.168.200.10

group1

gw

2

90

-1

192.168.200.20

3

100

1

192.168.200.30

group1

gw

4

110

1

192.168.200.40

group2

gw

itsp

Brekeke PBX SCA Users
User: 300
[Settings] -> [Resource map]
line/1=gw/1
line/2=gw/2

User: 301
[Settings] -> [Resource map]
line/1=gw/1
line/2=itsp/1

If user 300 makes an outbound call from shared line 1, the call will apply route “outbound*1” with
resource set as “gw” and group as group1 and the call will be sent to the destination IP
192.168.200.10.
While user 300 is talking, if user 301 also makes an outbound call from shared line 1, the call will
apply route “outbound*4” with the resource set as “gw” and the group as group2 and the call will
be sent to the destination IP 192.168.200.40.
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As explained in the above section about Max Sessions, routes in the same group use the same
session counter. In this example, routes “outbound*1” and “outbound*3” with resource “gw” are
both in “group1” and both routes have the [Max Sessions] variable v2 set to 1. When user 300 is
making a call through route “outbound*1,” the number of sessions in group1 is 1, which will
reach the [Max Sessions] in both routes “outbound*1” and “outbound*3.” Brekeke PBX will then
look for the next available route with resource “gw” for user 301’s outbound call. This is route
“outbound*4.”

The above example explains that the [Resource] setting is used for Brekeke PBX users to look
for available routes to make outbound calls and that the [Group] setting is used to limit max
sessions through the routes of both Patterns – IN and Patterns – OUT in the same group.



Multiple groups can be set in an ARS route [Group] field with group names separated by commas.



When a session goes though a route set with multiple groups, the session counter of the related
groups will increase by 1.

5.23. DID
From the [DID] menu, administrators can access and modify the active routes setup.
For MT Edition, only the active DID route related to the tenant will appear in tenant administrator
accounts. Tenant administrators can modify the route fields as necessary.

The following steps show how to enable DID access for a route and to set DID access
privileges.
Step 1: Enable DID Menu
1)

Log in to Brekeke PBX Admintool as system administrator (sa).

2)

Go to the [Options] > [User Access Settings] page in the [Admin Menu] section.

3)

Select on in [DID] menu.

Step 2: Enable a Route’s DID Access
1)

Log in to Brekeke PBX Admintool as system administrator (sa).

2)

Go to [ARS] and select an active ARS route template that can be accessed from a non-sa
administrator’s [DID] menu.

3)

Go to the selected route template’s [Variable Setting] page, click on the [Field Settings] link
next to [Route Local Settings].

4)

Select [Yes …] in the [DID] field.
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[No] disables access to the routes from the DID menu in administrators’ accounts.
[Yes (Modify only)] enables access to the active routes under the route template from
administrators’ accounts, which administrators can use to modify a route’s variable
settings.
[Yes (Modify/Add/Delete)] enables access to all routes under the route template from
administrators’ accounts, which administrators can use to modify a route’s variable settings,
to enable or disable a route and to add or delete a route.


5)

The [Yes (Modify/Add/Delete)] option is not available for Brekeke PBX MT Edition.

For Brekeke PBX MT Edition, set the tenant administrator’s access privilege for each
variable to one of the following options:
[Tenant Access (List)] enables or disables displaying of the variable in the route table of
tenant administrator accounts.
[Tenant Access (Edit)], if checked, allows the variable settings to be modified from tenant
administrator accounts. If unchecked, the variable settings will not be modifiable from
tenant administrator accounts.
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6.

System Setup

6.1.

Start / Shutdown

At the [Start / Shutdown] page, the system administrator can perform the following functions:
Check Brekeke PBX and its bundled SIP Server running status; check current events, such as
ARS route registration history; restart or shutdown Brekeke PBX and bundled SIP Server.


6.2.

Media Server running status has been added for the v3.4 or later.

Options

The following list displays the settings under the [Options] menu, which is only available to
system administrators:

6.2.1.

Settings



General Settings

Name

Default value

Description
Auto: Brekeke PBX starts up automatically with the

Start up

Auto

Tomcat (Brekeke PBX HTTP Service).
Manual: Start up manually.
Options: Auto / Manual



From v 3.6.x, The [Start up] item is moved under

[Start/Shutdown] menu as an [Auto Start] check

box.



PBX System Settings

Name

Default value

Description

Call pickup prefix

*

Prefix for picking up calls.

Port number

5052

Max concurrent

Depends on

Maximum number of concurrent sessions that

sessions

license

Brekeke PBX can handle (cannot be modified).

Max number of

Depends on

Maximum number of SIP UAs that Brekeke PBX

UAs (User Agents)

license

can handle (cannot be modified).

Min RTP port

30000

Max RTP port

49999
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on – RTP is handled by Brekeke PBX.
off – RTP is not handled by Brekeke PBX.
RTP relay

on

(Applied unless there is a different RTP relay setting
specified at the user phone type or the ARS
Routes.)
on – need to set [RTP relay] on, enable SRTP for all
calls at Brekeke PBX system

SRTP

off

off – applied unless there is a different SRTP setting
specified at the user extension phone type or the
ARS route [SRTP] field
on – need to set [RTP relay] on, enable video for all
calls at Brekeke PBX system

Video

off

off – applied unless there is a different video setting
specified at the user extension phone type or the
ARS route [Video] field
G.711 u-law (PCMU) is used by default. When
specifying multiple payloads, separate them with a
comma (,). The following payload types can be used
at Brekeke PBX:
0 - G.711 u-law
8 - G.711 A-law

Codec priority

0

18 - G.729
98 – iLBC
If the codec priority is not set in ARS Routes or user
phone type, this setting will be applied.
From Brekeke PBX v3.3.x, Brekeke PBX supports
dynamic payload type of iLBC even only payload 98
can be set for iLBC from Brekeke PBX Admintool
[Codec priority] field.
Use the codec setting that is preferred at the remote

Use remote
preferred codec

no

SIP UA. If “default” is set in [Use Remote Preferred
Codec] or in ARS or user phone type, this setting
will be applied.

Max concurrent
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recording.

recording
sessions
Use user’s name
as Display Name
Ringing timeout
(ms)
Talking timeout
(ms)

Max hop number
Days to keep call
logs
Session Timer
(sec, 0=disable)
Session keep alive
(sec)
RTP Session
Timeout (ms)

Yes

240000

Amount of time to wait for an answer from the dialed
party after ringing starts.
Maximum length of time a call can last in talking,

259200000

measured by the amount of time since the last SIP
packet was received. Value 0 signifies infinite.

20

90

0

Maximum number of SIP servers or Brekeke PBX
that a call can go through (hop number).
Number of days to keep call logs.
Interval to allow UAs and SIP server to determine
whether the SIP session is still active.
Interval to send keep-alive packets to UAs during a

600

call when RTP relay is set to off and session timer
has not been used.

600000

100rel

off

RFC2833

on

Timeout value for Brekeke PBX awaiting the next
RTP packet.
Enable (on) / Disable (off) for using reliable
provisional responses (1xx series).
Enable (on) / Disable (off) RFC2833 setting.
Web service security – used by Brekeke PAL and

Valid client IP

Brekeke Web Service; Set with regular expressions

pattern

of the PAL and Web Service clients IP pattern.

Java VM

Parameters passed to VM.

arguments


Use user account name as display name.

Media Server System Settings

Name

Default value

Port number

5056

Max concurrent

Depends upon
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session limit

the license

Media server (cannot be modified).
G.711 u-law (PCMU) is used by default. Separate

Codec priority

0

with comma (,) when specifying multiple codecs.
Also see the PBX [Codec priority] description.

Use remote
preferred codec
Max stored
messages

no

50

by the endpoints.
Maximum number of saved voicemail messages,
plus any recorded files for each user’s voicemail.
Maximum length of recording time for a voicemail

Message
recording length

Enable (no) / Disable (yes) on using remote codec

600

message. If [Message recording length (sec)] in

(sec)

User setting is blank, this value will be applied.

Days to keep

Number of days before unsaved messages are

unsaved

30

deleted automatically from each user’s voicemail
inbox.

messages
Conversation
recording length

3600

Maximum recording length for each call.

(sec)
Yes – save recording file in user’s voicemail box.

Conversation
recording file in

Yes

box, but show recording files in call logs.

voicemail inbox
Days to keep
conversation

30

recording files
Min RTP port

50000

Max RTP port

59999

Ringing timeout
(ms)
Talking timeout
(ms)
RTP Session
Timeout (ms)
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Java VM
arguments


Parameters passed to VM.

ms = 0.001 second
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Email Settings

Name

Default value

Description
The SMTP server address for sending email
notifications

SMTP Server

when the user

receives a new

voicemail message.
SMTP port
SMTP
authentication
Encrypted
connection (SSL)

25
on

off

Enable (on) / Disable (off) SMTP authentication
setting.
Enable (on) / Disable (off) Encrypted Connection
(SSL), available in v2.3 or later.
Address of the POP3 server (for POP-before-SMTP

POP3 server
POP3 port

SMTP server’s listening port.

authentication).
110

POP3 server’s listening port.
Email account username for the above SMTP

User

server.
Email account password.

Password
Password

Input field for confirming the above password.

(confirm)
Email address

Email notification sender’s address.

(from)

Email subject for the email notifications.
The following variables can be configured:
{from}: SIP URI who left the voicemail message

Email subject

voicemail({to})
: from {from}

{to}: voicemail box’s SIP URI
{from-number}: number in {from}
{to-number}: number in {to}
{time}: time when the messaged is recorded
{recording-length}: length in time of the recorded
message

from:{from}

Email body

to:{to}

Email body for email notifications.

time:{time}

Variables that can be used in this field are the same

recording

as in the [Email subject] above.

length(sec):{re
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cording-length




From v3.6.x, the mail server setting parameters are moved under the [Email] menu -> [Settings].

Multi-tenant Settings (MT Edition)

Name
G. 729 License
Sharing



Default value

Description
on – G.729 codec license is shared among tenants.

on

off – The number of G.729 codec licenses is set on
each tenant’s [Options] page.

PAL Settings

Name
Notification for
registration

Default value

Description
Sends notification to Brekeke PAL or Brekeke PAL

yes

WebSocket application (or not) when a user phone
has registered.
This field has been available in v 3.4 or later.

PAL WebSocket

yes

Yes – PAL WebSocket is enabled.
No – PAL WebSocket is disabled.
Web service security – used by Brekeke PAL

Valid WebSocket

WebSocket; Set with regular expressions of the

client IP Pattern

6.2.2.

WebSocket clients IP pattern.

User Access Settings

Restricts the features and menus that are displayed and modifiable from a User or Admin
account when the user logs into Brekeke PBX Admintool.

6.2.3.

Phone Type
Name

Default value

Description
The default phone types that users can choose.

Type 1
Type name

Type 2
Type 3
Web Phone*

User extension > [Phones] page [Type] field.
Default setting is Type 1.
*[Web Phone] is added for v3.6 or later. This phone
type is used when the bundled web phone is used.
Currently in v3.6, the web phone is provided as a
beta release. It will be provided as a standard
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release in v3.7.
Describe phone type.

Description

When set to :yes, Brekeke PBX provides a WebRTC
WebRTC

no

connection to WebRTC clients that have phones
assigned to this Phone Type.
When set to default, user phones assigned with this
phone type will apply the RTP relay setting in the

RTP relay

default

[Options] menu.
When set to off, Brekeke PBX will not relay RTP for
the user phones assigned with this phone type.
default – user phones assigned with this phone type
will apply the SRTP setting in the [Options] menu.
Optional – Both RTP and SRTP calls can be made
with the user phones assigned with this phone type.

SRTP

default

Available with [RTP relay] on
mandatory – only SRTP call will be made with the
user phones assigned with this phone type.
Available with [RTP relay] on
off – Brekeke PBX will not enable SRTP for the calls
with the user phones assigned with this phone type
default – the user phones assigned with this phone
type will apply the video setting in the [Options]
menu.

Video

default

On – Brekeke PBX will enable video for the calls of
the user phones assigned with this phone type
off – Brekeke PBX will not enable video for the calls
of the user phones assigned with this phone type
The default setting will apply the [Codec Priority]
setting in the [Options] menu.
Brekeke PBX will first apply the [Codec Priority]

Codec priority

setting in the phone type assigned to user phones if
the setting in the phone type is different from the
one in the [Options] menu.

Use remote

48
p-adm-b3.6.2_161115

default

When set to default, the setting in the [Options]

Brekeke PBX Administrator’s Guide (Basic)

BREKEKE SOFTWARE, INC.

menu will be applied.

preferred codec

Brekeke PBX will first apply the setting in the phone
type assigned to user phones if the setting in the
phone type is different from the one in the [Options]
menu.
When set to on, the phones assigned with this
phone
Keypad
commands

on

type

can

use

Brekeke

PBX

keypad

commands, such as #9, #8, etc.
When set to off, the phones assigned with this
phone type cannot use Brekeke PBX keypad
commands.
When set to off, the phones assigned with this

MWI (NOTIFY
without

off

SUBSCRIBE)

phone type can send SUBSCRIBE for MWI.
When set to on, the phones assigned with this
phone type cannot send SUBSCRIBE for MWI.
This feature has been available in v 3.4 or later.
Add as a prefix – Tag feature is enabled. Tag value
is displayed as an added prefix of a “from” header

Tag in Display
Name

off

on the devices assigned with this phone type.
Replace – Tag feature is enabled. Tag value is
displayed as a “from” header on the devices
assigned with this phone type.
Off – This feature is disabled.

Update remote
party ID

Stand-alone video
client

Properties

6.2.4.

When “re-INVITE” is set at this setting, remote-party
off

ID will be updated with a re-INVITE request. This
feature has been added in the v3.6 or later.
Video client is available for use when this is set to

off

“on”, a video client is available for use. This feature
has been added in the v3.6 or later.
Set properties that do not have corresponding fields
in Brekeke PBX Admintool.

Auto Sync

The [Auto Sync] menu is used for Brekeke PBX redundancy setup. This feature requires a
license upgrade.
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6.2.5.

SA (MT Edition)

SA is the only system administrator in Brekeke PBX MT Edition. From the [SA] page, you can
change the SA login password and set the system language.



From v3.6, The [SA] section is integrated with [System Administrators] menu. With this
change, multiple administrators can be created under one system.

6.2.6.

Advanced

The [Advanced] field allows you to set properties that do not have corresponding fields in
Brekeke PBX Admintool. Please refer to other manuals and tutorials regarding the type of
properties that may be edited here.

6.3.

Voice Prompts

6.3.1.

System Voice Prompts

Upload a customized sound file to overwrite the system default sound file, or to use as needed.
A list of Name, Language and Description will be displayed.

Name

Description

Language

Choose folder in which to save an uploaded file.
Name for the uploaded file in the folder.

Name

If the file name is the same as the system default sound file, the
uploaded sound file will be played.

Description
File name

Download

Delete

6.3.2.

A memo shown on the GUI to describe the file usage.
To upload a file, click the [Browse] button. Select the file you want to
upload and click [Upload]. The upload will then start.
To download a recorded sound file, click Download (

). The file will

be downloaded to your PC as a WAV file.
To delete a recorded sound file, click Delete (

). The selected file(s)

will be deleted.

Notes for Sound Files

Uploaded sound files must be formatted as below:
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Sample rate

8000 Hz

Bit-depth

16-bit

Channels

Mono

You may use sound-recording applications, such as Windows Microsoft Sound Recorder, to
record sound files. We recommend that you adjust the pause and sound level to suit your
needs.

6.4.

Automatic Route Selection (ARS)

Brekeke PBX automatically selects the optimum call route from the preset routing options. This
feature can be used for Least Cost Routing, traffic management and load balancing of VoIP
Gateways or PBXs.

6.4.1.

Adding a New Route

1)

Choose [ARS] > [New Route].

2)

Type the name of a route in the input field on the new popup window.

3)

Click [OK] to add the route.



In Brekeke PBX v3.0.x, choose [ARS] > [Settings] > [New Route].

6.4.2.

Editing, Copying or Deleting a Route

1)

Uncheck [Hide Disabled Rules] to show all ARS routes and details.

2)

Click the ARS route name to edit a route.

3)

Choose the copy or delete icon to perform the desired action.



In Brekeke PBX v3.0.x, select [ARS] > [Settings] from the submenu.

6.4.3.

Viewing an Active Route

1)

Check [Hide Disabled Rules] to display active rules only.

2)

Click “View” in [Status(Reg/Route)] to show details about the active route.
For the routes in an ARS template, click the ARS route template name and then “View” an
active route under the route template.



In Brekeke PBX v3.0.x, choose [ARS] > [Running Status]. If no ARS route is enabled, there will be no
route displayed under [Running Status]. Selecting [Settings] will display all ARS Routes.

6.4.4.


ARS > Route Template
General
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Name

Default value

Description

Route name

Name of the route.

Description

Description of the route.
Define if this route is a template (Brekeke PBX v3.1.x

Template

or later).

Disabled

checked

Disable / Enable the ARS route.

Type

Type A

Used for special functions.
ID for a group of ARS routes.

Group
External

unchecked

LineKey

unchecked

When checked, Brekeke PBX will recognize this ARS
route as an external line.
Check if you use Line keys (optional feature).
Set the interval period between sessions for any

Session interval

VoIP FXO Gateways that require pausing between

(ms)

sessions.
This setting takes effect when there is a registration
setup in the route.

Apply this route
for incoming calls

Yes

If set to yes, the incoming calls will apply this ARS
route only when the INVITE request URL is the same
as the one in the contact header of the REGISTER
request sent by this route.
Set the resource name for users with the SCA
feature enabled (optional feature, Brekeke PBX

Resource

v3.1.x or later).
Set a tenant name.

Tenant (MT Edition)


Registration

Name

Default value

Description
SIP URI that is used to register Brekeke PBX at a

Register URI

remote registrar server. Leave this blank when there
is no need to register Brekeke PBX to any remote
registrar server.
IP address of the registrar server. This field is

Proxy address

optional when the proxy address is the same as the
address set in the Register URI field.
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Register expire
(sec)
Register update
period (%)

3600

Set when REGISTER expires.
The percentage value of the interval until re-register

90

occurs, calculated from the length specified in the
register expire setting above.
User ID for authentication account required by
remote registrar server. Entry is not necessary when

User

authentication is not used.
Password for authentication account required by
remote registrar server. Entry is not necessary when

Password

authentication is not used.


Pattern – IN
Default

Name

value
100

Priority

Description
Lower numbers hold a higher priority.
Specify

-1

Max sessions

the

(including

number

of

RINGING

sessions

and

BYE

sessions) that are allocated to the
route.

unchecked

Disabled

Enable / Disable this pattern.
Specify a matching rule for the From

From

header

using

regular

expressions.

When the field is left blank, all calls will
be considered as matched.
Specify a matching rule for the To

To
Matching patterns

header

using

regular

expressions.

When the field is left blank, all calls will
be considered as matched.

Plugin
Param

Return
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Apply to
Request URI

If checked, compares the Request URI
unchecked

instead of To

designed for using ITSP accounts.

Apply only to
calls related to

unchecked

registration

If checked, the route only applies to the
calls related to registration.
Specify replace patterns for the From

From
Deploy patterns

instead of the To header; mostly

header using regular expressions.
Specify replace patterns for the To

To

header using regular expressions.

Custom

Used for special functions.
Select RTP relay ON / OFF.
If default is selected, the setting will be

RTP relay

default

the same as [Options] > [RTP relay]
(unless specified at the User settings).
on – RTP is handled by PBX.
off – RTP is not handled by PBX.
If default is selected, the setting will be
the same as [Options] > [SRTP] (unless

Parameters

specified at the User settings).
off – SRTP is not handled by PBX.
SRTP

default

optional – Brekeke PBX will handle
both RTP and SRTP call; available with
[RTP relay] on
mandatory – only SRTP call will be
handled by Brekeke PBX; available
with [RTP relay] on
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Specify codec to be used. Use a
comma (,) when specifying multiple
payloads. The following payload types
may be used with Brekeke PBX:
0 - G.711 u-law
8 - G.711 A-law
Codec priority

18 - G.729
98 – iLBC
From Brekeke PBX v3.3.x, Brekeke
PBX supports dynamic payload type of
iLBC even only payload 98 can be set
for iLBC from Brekeke PBX Admintool
[Codec priority] field.
Enable (on) / Disable (off) for using the

Use remote
preferred

default

codec
Block SIP
INFO (DTMF)

remote codec used by the endpoints.
When set to default, the remote codec
in the [Options] setting will be applied.

no

Block or pass-through the SIP INFO
(DTMF) from a user to the other party.
off – PBX will not handle RTCP

Send RTCP

off

packets.
on – PBX will handle RTCP packets.
Default: depends on the response from
the callee.
Block: remove SDP.

SDP 18x

default

Append: attach SDP.
If SDP is not included in the packets,
Brekeke PBX will play the Ring-Back
Tone.
If default is selected, the setting will be
the same as [Options] > [Video] (unless

Video

default

specified at the User settings).
on – video call is handled by PBX,
off – video is not handled by PBX.
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Patterns – OUT
Default

Name

value
100

Priority

Description
Lower numbers hold a higher priority.
Specify

-1

Max sessions

the

(including

number

of

RINGING

sessions

and

BYE

sessions) that are allocated to the
priority.

unchecked

Disabled

Enable / Disable this pattern.
Specify a matching rule for the From
header

From

using

regular

expressions.

When the field is left blank, all calls will
be considered as matched.
Specify a matching rule for the To
header

To

using

regular

expressions.

When the field is left blank, all calls will
be considered as matched.
Mostly designed for multiple ITSP

Matching
patterns

User

^.+$

accounts, it specifies the users to which
this ARS Route applies.

Class
Plugin
Param

Return

From

Deploy patterns

To

Specifies the users in the class to
which this ARS Route applies.
Java class name for the plug-in.
The parameters which will be used by
the plug-in.
The pattern of the value returned by the
plug-in.
Specify replace patterns for the From
header using regular expressions.
Specify replace patterns for the To
header using regular expressions.
Destination IP address. May omit entry

Target

when the destination IP address is
specified in the To header domain.
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When DTMF needs to be issued after
calling a gateway (two-stage calling),

DTMF

you can specify the DTMF string using
some part of the [To] matching pattern.
Define the voice prompt used with a

Confirm
Key

confirm call.
5

Custom

Define the confirm key entry.
Used for special functions.
Select RTP relay ON / OFF.
If default is selected, this value is the
same as in [Option] menu > [RTP relay]

RTP relay

default

(unless specified at the User settings).
on – RTP is handled by Brekeke PBX.
off – RTP is not handled by Brekeke
PBX.
If default is selected, the setting will be
the same as [Options] > [SRTP] (unless
specified at the User settings).
off – SRTP is not handled by PBX.

Parameters
SRTP

default

optional – Brekeke PBX hande both
RTP and SRTP call; available with
[RTP relay] on
mandatory – only SRTP call will be
handled by Brekeke PBX; available
with [RTP relay] on
Specify codec to be used. Use a

Codec priority

comma (,) when specifying multiple
codecs.

Block SIP
INFO (DTMF)
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off – Brekeke PBX will not handle
Send RTCP

off

RTCP packets.
on – Brekeke PBX will handle RTCP
packets.

Session
timer(sec,

Interval to allow both UAs and SIP
0

0=disable)
100rel

server to determine whether the SIP
session is still active.

off

Enable (on) / Disable (off) using reliable
provisional responses (1xx series).
If default is selected, the setting will be
the same as [Options] > [Video] (unless

Video

default

specified at the User settings).
on – video call is handled by PBX
off – video is not handled by PBX.

Next route on
failure

no

Disable on
registration

no

failure
Response
timeout (ms)

Set failover for outbound sessions (or
not).
Enable (yes) / Disable (no) this Pattern
when registration fails.
Period of time when a response has not

-1

been

received

timeout

is

activated.
Failover

Error codes

before

500

will

be

activated

when

specified error codes are received for
INVITE requests.

Recovery time
(ms)

0

Period of time until this pattern will be
reactivated.
Disable this route when using this OUT
pattern fails. Can also be set to disable

Disable on
failure

one pattern in the ARS route or multiple
This route

ARS routes with the same group ID.

Options:
This route, This pattern, This group
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6.5.

DID

Displays a list of DID-enabled routes. Administrators can modifiy enabled route fields, such as
changing the destination extension where inbound calls to a related DID number will be sent.
For more detailed setting instructions, please refer to the DID section above.

6.6.

Call Status

The Call Status of ongoing calls is displayed under the [Call Status] menu. By specifying search
criteria, the search result will be displayed on the screen. You can view detailed information for
the selected search result.

Name

Description

Total

Total number of system active sessions

ID

Call ID

Status

Call status: In progress, Talking

UAs

Users’ phone numbers in the current session

6.6.1.

Status
Name

Description

ID

Call ID

Status

Call status

Call park

The number that has been parked

Conference

Conference number

Start

Time the call begins

6.6.2.

UAs (User Agents)
Name

Description

User

Username

ARS

Used ARS route

URI

SIP URI

Connected

Time the call begins

Disconnect

6.7.

Disconnect the call. (If the user does not have the right to disconnect,
this option will not be displayed.)

Call Logs

Call log information is available through Brekeke PBX. By specifying a date, you can view the
59
p-adm-b3.6.2_161115

Brekeke PBX Administrator’s Guide (Basic)

BREKEKE SOFTWARE, INC.

call log information for that date. By default, call log information is displayed in html in the
browser. By clicking the [csv] button, you can download a log file to your local machine in .CSV
format. Individual user call logs are also available under each user.

6.8.

Notes

This menu item is used by Brekeke PBX plug-ins to access text data or to save script files for
IVR script users. You can also use it for writing some memos.

Name

Description

Name

Name of the note

Description

Brief description of the note
Define if this note can be accessed by users, as well as what the

User access level

access level is.
Select from “No Access,” “Read only” or “Read/Write.”

Note

6.9.

Text field where you can write your own notes

Extensions

On the left menu panel, click the [Extension] menu. Select different extension tabs and create
extensions. Click Extension to edit this extension setting.
For user extension setting details, refer to the Brekeke PBX User Guide.

6.9.1.

System Administrator
Name

Default value

Description

User type

Admin

Administrator user

User

sa

Default administrator username

Login password

sa

Default administrator login password

6.9.2.

Group Extensions



Simultaneous Ring Group

Name

Default value

Extension

Extension
Type
Description
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User extensions’ IDs to which Brekeke PBX will
forward a ring group call.

Group extensions*

Separate user extensions with commas.
The ring time settingof each extension is applied

Apply each
extension's ring

yes

time

instead of the value of the [Ringer time (sec)] when
this is set to “yes". This field has been added in the
v3.6 or later.
Amount of time phone will ring while waiting for the
recipient to answer. After the length of time set here,

Ringer time (sec)*

90

the call will be transferred to the destination that is
specified

in

the

[Forwarding

destination

(No

answer)] field. If no destination is set at [Forwarding
destination (No answer)], the call will be terminated.
Forwarding

Destination to which the call will be forwarded when

destination (no

ringer timeout has occurred.

answer)

Tag the call (Brekeke PBX v3.4. or later).

Tag


Call Hunting Group

Name

Default value

Extension

Extension
Type

Description

Call Hunting

Extension type
Extension description

Description

There are two modes for call forwarding:
Round-robin – Calls will be distributed starting from
the top of the list. When a call is received, it is
Mode

Round-robin

forwarded to the extension following the last
extension that received a call.
Top-down – Calls will always be distributed in the
order listed in the field, beginning with the first
number.

Hunt group

Enter extension number(s) to which all calls that are

extensions*

received at this extension number will be forwarded.
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The ring time of each extension is applied instead of

Apply each
extension's ring

ｙes

time

the value of the [Ringer time (sec)] when this is set
to “ｙes”. This field has been added from v3.6 or
later.
Time interval Brekeke PBX waits before ringing
each destination in the [Hunt group extensions*]
field.
Multiple time intervals can be set and separated by
commas, such as, “5,15,0,10.”

Ringer time (sec)*

20

With this setting, Brekeke PBX will ring the first
destination when there is an incoming call, then wait
for

five

seconds

before

ringing

the

second

destination, then wait 15 seconds to ring third and
fourth destinations together (because the third ring
time is set to 0), and then wait ten seconds to ring
the final destination.
Waiting time in the
queue (sec)
Max number of
calls in the queue
Call interval
(msec)

Length of time queued calls will remain on hold
0

before forwarding to the user destination set at
[Forwarding destination (No answer)].

10

Maximum number of calls that can wait in the queue
at one time.
Amount of time to wait between dialing the available

3000

extensions in [Hung group extensions*] while callers
are waiting in the queue.
Enable / Disable retrying calls when an initial call
has not been answered.

Single attempt

no

When this setting is enabled, the call will be
transferred to the destination set at [Forwarding
destination (No answer)] after the initial call is not
answered.

Forwarding
destination (No
Answer)

Destination to which the call will be forwarded when
timeout has occurred.

Sound Files
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Name

Description
Audio file that contains the music/sound that

Music on hold

will be played when the caller is on hold.
Tag the call (v3.4 or later).

Tag

Options in the queue (From Brekeke PBX v3.6 or later)
Name

Default value

Description

Transfer

Destinations to which the call will be forwarded

destinations* (0-9)

when DTMF is received (0-9).

DTMF Timeout

20

Length of time to wait for inputting destination
number

Music on hold in

Audio file that contains the music/sound that will be

the queue

played when the caller is on hold in the queue.
Audio file that contains the music/sound that will be
played after the audio of [Music on hold in the

Prompt for options

queue] is ended.

6.9.3.

Schedule Extensions
Name

Default value

Description

Extension

Extension

Description

Extension description
Destination number to forward all calls that are
received by this extension. Calls will be forwarded to
the appropriate destination based on conditions

Forward To

defined in the schedule.
The Tag field has been available since Brekeke PBX
version 3.4.X. You can set an arbitrary string in the
field.
Specify

Conditions

schedule

information

for

forwarding

incoming calls.
Tag can be added to calls as a part of the conditions
in the v3.4 or later.

Name

Description

Default forwarding schedule*

Calls will be forwarded to the destination set here
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when no other schedules can be applied to the call.
Forwarding schedule [n]

Calls will be directed to the destination set here
when the conditions are met.
Multiple schedule plans can be created under a
single extension.

Plan [n]

The active plan will be applied to calls.
Specify the schedule when a plan will be active.

Timer 1/Timer 2

6.9.4.

IVR Extensions

For the IVR type [Flow] and [Script], refer to Brekeke PBX document – Developer’s Guide: IVR


Auto Attendant

Name

Default value

Extension

Extension
Type

Description

Auto Attendant

Extension type
Extension description

Description
Language

English

Select IVR language.

Max input digits

4

Maximum number of input digits
Maximum number of retries when an input error has

Max retry count

5

occurred. After this number of retries has occurred,
the call will be terminated.

Ring timeout (sec)

30

(sec)
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Set up “Speed dial” numbers for Auto Attendant.
Example:


1=100 In this case, instead of dialing 100 to
reach user 100, a caller can dial 1.



1==100 In this case, a caller can dial either
110# to reach user 110, or dial 1# to reach the

Speed dial

user who is set as 100 in speed dial.


Regular expressions can be used for detecting
input number pattern
^9.+$=100 In this case, all calls with inputting
number starting with 9 will be transferred to
user 100

Enables / Disables call transfers to an unregistered

Transfer to
unregistered

disable

user.
Options: disable / enable

users

This feature has been available since version 3.4.X.
Media before
answer

Enables (on) / Disables (off) – Allows the transfer of
off

media packets from an external source before
Brekeke PBX receives an answer.

Sound Files
Name

Description
Greeting message that is played for the Auto

Greeting message

Attendant.
A message to prompt the caller to re-enter the

Retry message

number when an input error has occurred.
Audio file that contains the music/sound that will be

Music on hold



played when the caller is on hold.

Add / Remove Forwarding Destinations

Name
Extension
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Add / Remove
Type

forwarding

Extension type

destinations
Extension description

Description
Language

English

Select IVR language.
By calling this extension, the caller’s extension
number will be added or deleted from the [Group

Target groups*

Extensions] field for any group extensions that are
set in this field.



Switch Plan

Name

Default value

Extension

Extension
Type

Switch Plan

Extension type
Extension description

Description
Language

Description

English

Select IVR language.
By calling this extension, the caller extension’s

Plan number

2

[Inbound] page active plan value will change to the
value set here.
When set to yes, the plan number will be set as the
active plan when a user calls this extension. The
active plan will switch back to plan 1 when the user

On/Off

Yes

calls this extension again.
When set to no, the plan number will be set as the
active plan when a user calls this extension, but will
not switch back to plan 1, regardless of how many
times the user calls this extension.
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6.9.5.

Conference Extensions
Name

Default value

Description

Extension

Extension

Description

Extension description
By specifying user extensions here, a user can dial

Auto Invite

this extension to invite multiple attendees to a

attendees*
Apply conf
extension to From

conference.
no

Yes – Attendees can automatically see the
conference extension number on their devices.
Number patterns of callers who can join a
conference.

Applies to (caller
numbers) *

Wildcard characters can be used.
*

A star (*) and a question mark (?) can be used for
matching meta-characters. A star (*) means zero (0)
or more characters; a question mark (?) means one
character.
Available inv3.4 or later. By specifying a user
extension here, that user is defined as the host of

Host (1st attendee

the conference. If no one is specified here, or if

if left empty)

using v3.3.X or earlier, the user who enters the
conference first is defined as the host of the
conference.
Yes – when call host hangs up, conference call will

Exit all when host
leaves

end.
no

No – when call host hangs up, conference call will
continue if there are attendees in the conference
room.

Broadcast
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When set to yes, and attendees PBX user already
Hang up existing
calls

have another call in conversation at the time the
no

conference call is initiated, Brekeke PBX will
disconnect their current talking call and ring the
attendees for conference call.

Sound Files
Name

Description
Audio file that contains the music/sound that will be

Music on hold while waiting

played while waiting for other attendees to join the
conference.

6.9.6.

Callback Extensions
Name

Default value

Description

Extension

Extension

Description

Extension description

Ringer time (sec)

90

Forwarding
destination (no
answer)

Amount of time phone will ring before directing the
call to the forwarding destination.
Destination where the caller will be directed when
ringing times out.
Destination where Brekeke PBX will direct the caller

Callback callee

when he/she disconnects a call before ringer time
out.

7.

Setup Items (MT Edition)
For tenant menu details that are not listed below, please refer to the system-level explanation
above of the Tenant menu.

7.1.

Tenants

From this menu, a system administrator can create a new tenant, delete a tenant and copy and
modify existing tenant settings.


Shutting down Brekeke PBX MT Edition from Admintool is required when deleting a tenant.
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7.1.1.

Copy and Set Up New Tenant

1)

Click the copy icon of the tenant you wish to copy.

2)

At the popup window, type in the new tenant name.

3)

At the next screen, edit the setup for the new tenant and save the settings.

7.1.2.

Settings Copied in New Tenant

In the new tenant, the following settings will be the same as the tenant that you copied:


Users and user descriptions



User settings, except [Phone ID]



Voice prompts, including users’ voice prompts and tenant system voice prompts



Tenant options

Settings that will not be carried over:


Tenant descriptions



User extensions’ Phone IDs



Call logs



Voicemail – all users’ mailboxes will be empty.

7.2.

Tenant Voice Prompts

Upload a customized sound file under a tenant to overwrite the system default sound file or to
use as needed. The sound files uploaded at the tenant level will take effect only for the current
tenant and will have higher priority than the sound files uploaded at system [Voice Prompts]. A
list that includes Name, Language and Description will be displayed. For setup details, please
refer to system level voice prompts.

7.3.

Tenant Notes

This menu item is used by Brekeke PBX plug-ins to access text data or to save script files for
IVR script users at the tenant level. You can also use this feature for writing memos. Notes
created under a tenant have a higher priority than those created under system [Notes].
For setup details, please refer to system-level Notes.

The format for accessing tenant-level notes from Brekeke PBX plug-ins is as follows:
<tenant_name>.<note_name>
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7.4.

Tenant Options

Tenant settings can be modified from the Options menu under each tenant.


General

Name

Description

Description

A brief description of the tenant



Capacity

Name

Description

Maximum users

Maximum number of user extensions allowed under this tenant

Maximum sessions

Maximum number of concurrent sessions allowed for this tenant

Maximum recording

Maximum number of concurrent recording sessions allowed for this

sessions

tenant

Maximum G.729
license

Maximum agents



Maximum number of concurrent G.729 sessions allowed for this
tenant when G.729 license is not shared among system
(license option required)
Maximum number of call center agents (license option required)
allowed for this tenant

Features

Name

Description

Voicemail

Enable or disable this feature for the tenant

Auto-Attendant

Enable or disable this feature for the tenant

Conferencing

Enable or disable this feature for the tenant

Call Recording

Enable or disable this feature for the tenant

Round Robin –
Topdown

Enable or disable this feature for the tenant

Call Queue

Enable or disable this feature for the tenant

PAL

Enable or disable this feature for the tenant

8.

Maintenance

8.1.

Back Up / Restore

You can back up current configurations and messages in users’ voicemail boxes from
[Maintenance] > [Back Up]. You can restore the backup data from the menu [Maintenance] >
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[Restore]. To best maintain your service, we recommend backing up Brekeke PBX on a regular
basis.

8.2.

Report (MT Edition)

Overview of all tenant setups that are hosted on the Brekeke PBX MT Edition system, as well as
system tenant settings reports that can be exported in csv format.

9.

Uninstallation

9.1.

Uninstalling from Windows OS
1)

Kill all Java processes (java.exe) used by Brekeke PBX from Task Manager.

2)

Navigate to Start / All Programs / Brekeke PBX / Uninstall Brekeke PBX. The uninstaller
will uninstall Brekeke PBX automatically.



If the uninstaller fails to delete the folder (C:\Program Files\Brekeke\pbx), you will need to restart the
PC and delete the folder manually.

9.2.

Uninstalling from Linux OS

Delete the file “pbx.war” and the folder “pbx” in the directory “webapps,” which is located under
the installation directory of Tomcat, then restart the machine.
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